Amethyst feedback

[color=#009900]We’re very glad to hear the new combat’s working out. Any specific niggles - ‘I didn’t understand this at first’ ‘this placement confused me’ ‘this is fiddly’ would less encouraging, but equally useful, to hear.[/color]

I know it sounds stupid, but I died several times because I was assuming - I think from previous placement - that a Devastating Salvo was just a Salvo.

OK, this is (I am sure) a really dumb Q, but I tell my students that in such cases there are other people who are too shy to ask :-) so… how DO captains toggle the lamp? I can’t find the control for it anywhere :) [Not that I really care - made it this far without ever turning it out - but it would probably be useful…]

Quick ‘just played for ten minutes while I should have been working’ impressions:

  1. Simply deleting the Entities directory seems to have fixed the “all the choices are visible” bug for me.
  2. I never ever ever noticed the previous “here’s the dock” indicator, so I really like the new “HERE’S THE DOCK!!!” circle. Slightly more subtle would be even better.
  3. LOVE the new combat. “Wait for warm up” is better than “wait for cool down”. I know it works out to the same time delay, but it just feel more ‘active’. I like the subtleties that come with knowing what the other guy’s going to do. The vertical labels feels off to me - but that could just be because I’m used to the previous horizontal text, though.

Leftover from the previous update that I never posted about: I love that the Admiral gives you little missions now - it helps push me out to exploration mode. Otherwise, I tend to spend a LOT of time trying to build up capital on the Venderbight run. I keep thinking “One more run and I can afford [doodad], and THEN I can afford to explore.” Having the “Go [place] and you’ll get a pile of cash” helps break me out of that.

Also, while I did rather like the spartan emptiness in the first betas, the filled-in map is going to be freaking awesome. (It also seems to help make Port Reports be the major source of income)

Great job so far, guys - really good progress from what we first saw. And the final version is just gonna rock the casbah.

The ‘L’ key or the lamp button at the bottom of the screen. =)

Either type &quotL&quot on the keyboard, or use the tiny little lightbulb icon at the bottom of the screen. I never use it, though (unless I’m trying to sneak past a Lifeberg).

[color=#009900]Yes indeed! That image needs updating. On the list now.[/color]

[color=#009900]This is the kernel of the reason why we did it. You’re now capable of making and act on a decision at any time, rather than being able to act on a decision only in the moment after the last action completed. There was a reason we went with the initial model at first, and it generated a lot of highly specific internal debate - I’ll do a blog post on it someday - but it didn’t work out. This is an instance of the beta process working as it should, and iteration helping us get things right. Thanks, all![/color]

Niiice historymongering.
[color=#009900] [/color]

I like it being more visible than it was before… but maybe a little less interface-y than it is now? It’s certainly helped me spot at least one docking point I would have missed, so, definite gameplay benefits.

Speaking of - before I used this fix, I was looking at the London options, and noticed one of the officer recruitment options is unlocked by already having that officer. Bug, or intentionally not-yet-implemented officer?

I like the new combat UI a lot - the Illumination meters, the action queue, the lot. If I had to niggle… the available actionss at the bottom make sense, and the queued actions in the middle make sense, but taken together… the enemy’s queued action is close enough to the options at the bottom that I sometimes get confused. Pretty minor, I admit. Also, I wouldn’t say no to having more slots in the action queue, either by default or as a result of levelling up. Oh, and it’s slightly confusing that Salvos aren’t arranged from weakest to strongest, top to bottom… but, like I say, pretty minor.

Other thoughts… I like the new enemies and spawning system! Except… is there any way to have the enemies spawn/wander less closely together in each area? The fast-moving ones always seem to be stuck to each other, and to all rush at me from the same direction when I approach. (The clay pirates seem to move and turn too fast for their size and shape, too, but if they’re just placeholders, then that barely counts as a quibble.)

Yeah well, nah.

Here’s a wonky off-kilter picture I took with my phone because I still can’t screenshot Sunless Sea properly for some reason.
It was hard as hell. I have 81 Veils and 64 Iron and it was still difficult to get any hits in between all its massive-Illumination Seeks. But I filled it with harpoons and it fell over. Hooray!
i have no idea why i did that

Agreed on Mt Nomad. Took me four tries, and that’s with both Veils and Iron well over 100.

The ones that are irritating me right now are the Khanate ships: they don’t announce themselves as placeholders, and can do damage, but for no purpose…

If I have parsed correctly, should be a better pic. The cliff yields a captivating treasure, but still not worth the effort :-).

[admin edit for giant spoiler image] - Oops :-(; sorry, folks, mea culpa.
edited by Alexis on 6/6/2014[li]
edited by Ewan C. on 6/6/2014

Alexis Kennedy[color=rgb(194, 194, 194)] wrote:[/color]
[color=rgb(119, 119, 170)][color=rgb(0, 153, 0)]- the all-visible-branches is confirmed as an issue that’s fixed by checking for new content. It sounds like the update hasn’t run cleanly for some folks - if you delete everything in the /entities folder in your AppData/LocalLow/FailbetterGames/SunlessSea folder (or, um, whatever the weird equivalent is with Macs) and run another update, that should fix it.[/color][/color][color=rgb(119, 119, 170)][color=rgb(0, 153, 0)]

I can’t find that file, so can’t delete it. I also tried just downloading from Humble Bundle and checking for updates but was told that I am up-to-date and I still have all the locked options in the ports
edited by reveurciel on 6/6/2014

[color=#009900]Congratulations, gentlemen. Mt Nomad is still semi-placeholder - it’s a Nemesis with a story of its own - but I wanted to put something in there.[/color]

[color=#009900]Drop us a line at the usual place and we’ll dig into the problem.

Just in the middle of my first enforced-half-speed episode, from being too successful at taking prize ships. Irritating, in the most ‘oh, yeah, this makes sense!’ pleasant kind of way :-))

[Although: if it only takes 5 of my crew to handle a pirate frigate, surely the remaining 19 of us can get this beast moving a little faster :-). And it occurs to me that prize crews apparently have no need of supplies; must be raiding the pirates’ larder.]
edited by Ewan C. on 6/6/2014

[color=#009900]Drop us a line at the usual place and we’ll dig into the problem.

Message sent, not sure if I provided all the information you will need to fix it but I’m not very good with computer stuff.

lady ciel, I am sure that folks here could/would also help. What OS are you using?

[quote=Liam Welton][color=#ff3300]Hi all!

I wanted to drill down into this steering issue people have been experiencing. If you have had that/have it again in a game you are currently playing, please submit a bug report with the output_log.txt attached, that will help us get to the bottom of it as quickly as possible.

As I’m unable to reproduce this myself, could I ask you as well to check a few things if you find it happening:

  • can you change your speed as well?
  • If you open the gazetteer, what tabs are greyed out?
  • Do beasties attack you?
  • Can you toggle your lights/use the zee-bat/repair?

Many thanks!

edited by challis on 6/6/2014[/quote]

Fresh download, data updated (but old data not deleted). New character. Triggered when I left port from the island with the three sisters.

I can’t steer or change speed. I can pause. I didn’t check the gazetteer.

While unable to steer I was attacked by two clouds of bats. After combat with one (which worked fine), the other one pushed me sideways across the map until I was killed by a pirate.

There is no file called output_log.txt anywhere on my system, nor any obvious log by any other name.

If someone could share where the relevant files (logs, state) are stored on OS X it’d be very helpful. Most of the state seems to live in &quot~/Library/Caches/unity.Failbetter Games.Sunless Sea&quot, but I’m not familiar enough with Unity to tell if that’s the right place.


Yep, and then in the subdirectory /entities

For me, deleting the content of that directory and then relaunching the game fixed a variety of issues :).