Amethyst feedback

Looks as though at some stage I am going to have to start a new game to remove the shipyard bug; Ah well. Later in the summer when I have time, I suspect, to properly mourn the 30K Echoes thus lost…[li]

…but in more useful feedback, the change to ports so that all possible event options are shown but most are greyed out really really (REALLY) clutters things detrimentally. If it’s at all possible to revert, that would be welcome. [I suspect that it may also allow for some unwelcome ability to predict which of several ‘explore’ options one will get without actually taking it?]

More to come, but that was a big thing that hit right up front.

Anyone else getting a steering bug?
I keep leaving port and not being able to steer… Just steam ahead at 1 speed in a straight line
It keeps rectifying itself after a few minutes but yeah means I can’t actually control my ship at all

Really quick feedback:

Amethyst is BRUTAL. I have a quick half hour muck about and…

Life one: Didn’t reach Venderbight. Blown up pirates half way there.

Life Two: Misjudged terror and food. Went mad and starved.

Life Three: Strange swirling black thing smashed me into a light ship until my ship was little more than canvas and match wood.

I had time to note that Venderbight had two ‘Explore Venderbight’ options. Also learned how to fight giant glowing crabs by having A LOT of experience in a short time. Wow. Bring on the weekend.

Yup Steering bug is making it impossible for me to play :/ It doesn’t happen everytime I leave port but when I do it will either suddenly go away or linger for up to five minutes and I can’t turn or slow down or speed up or anything…

[color=#009900]Sorry about this, folks. We’re seeing a few reports of the steering bug at this end - anything more you can tell us about when it occurs and details of your machine/install/save (at would be really helpful for tracking it down. Likewise the issue with should-be-invisible choices appearing, which certainly isn’t intentional.[/color]

[color=#009900]Generally: DO MAKE SURE YOU’VE CHECKED FOR NEW CONTENT! At least one user has found the choices bug fixed by doing this. There’s some changed data structure stuff that this will flush through.[/color]

[quote=Ewan C]
the change to ports so that all possible event options are shown but most are greyed out really really (REALLY) clutters things detrimentally. If it’s at all possible to revert, that would be welcome[/quote]

I don’t see this at all, and it’s not mentioned in the changelog either. Probably a bug! e; welp yes it is, sniped by alexis My steering works fine too. However, every time I press the Shops button the rightmost tenth of the screen gets slightly greyed out and slowly becomes opaque. Software bugs, hooray! need to send a bug report when I’ve got some time for that I guess.

Anyway ok there’s not actually much story content in the new islands (Void’s Approach has some on its islands, but Polythreme, the Cumean Canal, Godfall and Pigmote Island don’t actually have anything at the dock, although there’s plenty of stuff to kill around them). The Avid Horizon looks really really cool though! and the locked option there has me hype as heck.

The new combat interface looks way more slick and is also way better and a bit more challenging to boot. I harpooned some bats to death! Hooray! I haven’t found the one land battle yet although I can probably guess as to its location.

i bought an eyeless skull why did i do that

The Corsairs Forest is full of Corsairs. oh god. so many frigates.

I want to go have a rematch with Mt Nomad but I’ve not seen it since v1.1 when I killed two of them at once. You can’t tell me what to do!!!

E for dock works real well, the new docking indicator is way more noticeable than the old one so that’s probably good as well.

The engine false-start bug still seems to happen, but clicking the fuel button seemed to fix it.

Terror ratcheting up way faster (although half as intense) makes the whole flick lights on and off deal pretty much pointless. So fuel consumption is now a super big issue, fuel efficiency still doesn’t seem to do much either. Just faffing around down south was enough to burn 10 barrels of fuel in no time at all.
edited by Spacemarine9 on 6/5/2014

Initial feedback:

  • Yep, Amethyst is brutal. Terror is noticeably faster to accumulate; if I didn’t have a large stock of Echoes, I’m not sure how I’d get past Venderbight.

  • On my first trip from FL to VB, I was attacked by four separate pirates. I managed them fine, but I’ve also got ten hours into this character. Seemed a little much.

  • Still chewing on combat. Initial thought is that having enemies ‘use’ their first skill immediately on hitting ‘Resume’ for the first time puts the player at a small time disadvantage. Might be worth delaying it for 0.5 or 1 second.

  • Are the Void’s Reach ports intended to be mostly empty? [spoiler]I’ve got no options in Codex, only one option in Chapel (to eat some zeetuna, which doesn’t consume/require SAY), and one option in the arches that dumped a bunch of Terror on me for in exchange for one Fragment.[/quote]

Also, it might do to flag Mt. Nomad in a clearly non-textual way as Instant Death. The current description is evocative but doesn’t necessarily indicate Gandalf-grade orders to fly, fool.

I don’t know how much of this is bugs and how much is my installation is just broken. I’ve tried playing a version of Amethyst installed to the same folder as before, and to a different folder. I’ve tried existing saves and new characters and they all have the same problems:

  • All branches are visible, regardless of whether they can be performed or not. (Intentional?)[/li][li]I don’t see any enemies any more. They’re gone.[/li][li]No new islands or docks, though some placeholder art has been replaced (eg Godsfall)

I haven’t encountered the mentioned steering bug, though.

Also also, I assume that S on the Chapel of Light’s landmass is the land battle teased in the patch notes… but I can’t seem to get it to trigger. What’s up with that?

I have yet to get to Venderbight… I got swarmed to death by about 8 flocks of bats… It did not end well for me!

The new combat interface is nice, slick and easy to use and clear what I am doing. Though the enemies I have met so far seem to ramp up to blowing me to hell pretty quickly.

I’m not at all fond of the new port circle. I liked the more subtle one that looked like shallow harbor swells. This one takes me out of game because it looks so out of place.

I’m also getting the multiple locked out branches, and I did double check for new content before playing. I haven’t tried with a brand new game yet, though, so I’ll see if I still get it with that.

update; jesus christ. hell. argh.

My best attempt dealt 700 damage. I need more Iron and more Veils to have a hope at beating that thing, but Secrets give barely any stats now (+1 each, which is not a lot!) and there’s only one tier of gun with more Iron than the current one I have. hrg

i’m going to kill that mountain just you wait and see
edited by Spacemarine9 on 6/5/2014

How are you farming Secrets there, Spacemarine?

I don’t! Shuttling a new character with 110 Pages to Port Cecil is an incredible way to get far too many Secrets, but that only works on new characters and not on the established bloke with a frigate, a shiny gun and a full complement of officers. Reliably getting Secrets is kinda hard, I think; visiting new areas tends to give a lot (Polythreme alone is like 150 fragments), but there’s only so much to find out there.

My thoughts, ranked according to great, good, okay, bad, and ugly:


[ul][li]Dat combat interface. No longer at risk of death because I missed a cooldown click chance. Queued actions are amazing. My poor, abused left click button has been given a break, and it wanted to croak out an exhausted &quotthanks&quot to you. Seeing what my enemy is planning is excellent and lets me react accordingly. The explanation and log to the right is beautiful and easier to track than the illumination bar. I would like to see the bar display a number, but as it is right now, the interface is magic.

[ul][li]Spawn points marked on the map. I know where to expect gribblies now! [/li][li]Light vessels clearly marked.[/li][li]New enemies that aren’t ridiculously strong.[/li][li]Access to areas south of all the craziness north of London! The Cumaean Canal! Polythreme![/li][/ul]Okay:

[ul][li]New places mean I can finally get secrets. More things throughout the zee give it life, and makes things more interesting. The aesthetics of the Sea of Voices are deliciously creepy, although more named things would be lovely to see.

[ul][li]A lot of the enemies are disproportionately strong. Clay/unfinished pirates rip you apart in combat if you’re not using any of the 10k+ echo ships. Still unsure if flensing can actually affect crew or not.[/li][li]Terror seems to increase even faster.[/li][li]Still very few ways to make a large amount of echoes without repetitive action.[/li][li]The rare success at Quaker’s Haven for Rubbery Lumps is just an echo sink once your veils and iron are too high for it. It’s an echo sink even when it’s not, given how minute the increase is. Losing 50 entire echoes for that is like playing russian roulette. Not sure if that’s a bug or a feature. If it’s a bug, it’d be great for it to be fixed. If it’s a feature, I’m not sure why, and don’t really get the reasoning behind it.

[ul][li]Fuel. Fuel disappears so fast that I can go through two or more barrels just going to venderbight and back. Exploring isn’t something that can be done unless you’ve got 7+ barrels of fuel, and even then you’d best hope you can refuel halfway back to London. Having a fuel-efficient engine like the serpentine does nothing that different.[/li][li]Secrets and stats. This is arguably the most frustrating change. There’s no way to boost my stats more than a smidgen at a time, and the only way I get secrets is port cecil or exploring when new content comes out. That and pages only boosts at port cecil, which is further exacerbated by the issue with fuel.
edited by ZackOak on 6/6/2014
edited by ZackOak on 6/6/2014
edited by ZackOak on 6/6/2014
edited by ZackOak on 6/6/2014

My reaction to the update was basically NEW PLACES NEW PLACES I’M GONNA GO TO ALL THE NEW PLACES. I was slightly disappointed by them having either 0 or 1 playable storylets, but I was still delighted to explore all over the Cumaean Canal, Polythreme, Void’s Approach, and the Snares. (And get attacked by five or six bound-sharks whenever I go to the Snares.) And, hey, Codex got a description and a picture! I really want to explore Codex properly when it’s ready to go, it looks interesting.

I like the new combat system, although the rearrangement of the controls was a bit jarring the first time something attacked me.

I’m not a big fan of the port circle either. I liked the glowy spot that it was before. (Which was overlookable in some finished ports and only really obvious in placeholder ports out in the unfinished parts of the zee, and that seems like suboptimal design, but… I dunno. I liked it. Maybe if it were up to me I’d just make it glowier.)

I hadn’t noticed the reduced potency of feeding Secrets to your officers, I thought I was just getting a bunch of bad rolls from the RNG. That’s a change I don’t like; it’s hard enough to get Secrets with which to upgrade your stats in the first place, so having them give less stats when you get ahold of one is not a thing that I’m enthusiastic about. This might even out when the map’s bigger, as more places to chart and get secrets from become available, but right now I don’t like it.

[color=#ff3300]Hi all!

I wanted to drill down into this steering issue people have been experiencing. If you have had that/have it again in a game you are currently playing, please submit a bug report with the output_log.txt attached, that will help us get to the bottom of it as quickly as possible.

As I’m unable to reproduce this myself, could I ask you as well to check a few things if you find it happening:

  • can you change your speed as well?
  • If you open the gazetteer, what tabs are greyed out?
  • Do beasties attack you?
  • Can you toggle your lights/use the zee-bat/repair?

Many thanks!

edited by challis on 6/6/2014

[color=#009900]Woohoo, lots of feedback! Brilliant, chapoids, chapesses and chaplings. Many points:[/color]

[color=#009900] - Secrets cost / effect. &quotThis might even out when the map’s bigger, as more places to chart and get secrets from become available, &quot ← this. When we started the beta, you folks had access only to home waters and the near reaches, and we had to pack in the rewards accordingly. We’re now retuning for a much larger map and a longer game. Take a look at the map on a moment, and savour how much you have to come… we’re just about at a third of the world now (and it’s not impossible we’ll expand the map further east). Under the old regime, you’d be maxed out long before you’d found Irem or the Sea of Wings. So, yes, this feels like a pinch now - sorry about that. There are more labels and more reward opportunities with every update - you’ll see things ease out a bit.[/color]
[color=#009900] [/color]
[color=#009900] - Fuel usage - this will remain rapid, especially with bigger engines. It’s taken over from Hunger as a the primary restriction on exploring the map, because the aggressive Hunger rate in the first version just felt daft. Finding refuelling points is a significant concern, intentionally, and underscores the rhythm of returning to London - the ‘find your way home’ beat. Bigger ships can carry more fuel, but of course to move at the same speed may also need more powerful engines which use up more fuel - it’s a tradeoff. We’ll keep balancing the numbers.[/color]
[color=#009900] [/color]
[color=#009900] [sidebar: the Age of Steam came, of course, well after the European Age of Discovery. This made researching the historical context of the game surprisingly difficult, because nearly all the significant exploration history happened with tech that was two centuries older than what we’re playing with. No sane person would choose a steamship to explore an unknown ocean, because fuel is so much harder to find in unknown territory than is food and water… unless, of course, they’re navigating an ocean that has no wind.][/color]
[color=#009900] [/color]
[color=#009900]- Fuel efficiency does work, but it’s actually a percentage, so 10% fuel usage isn’t visible until you’re getting through a lot of fuel. Because later on we’ll have more items that stack, and 80% fuel usage reduction would wreck the game economy, it has to be small. I’m looking at ways to make this clearer on mouseover.[/color]
[color=#009900] [/color]
[color=#009900]- Flensing cannons should damage crew, but a quirk in the randomisation might mean the effect is haphazard. It’s on my list to look at.[/color]
[color=#009900] - We do have a bit of a difficulty spike on some enemies. You can run away from them now! but I’ll be tuning this in the near future, and it’ll show up in story updates.[/color]
[color=#009900] [/color]
[color=#009900] - Port circle. This was decidedly an experiment, and the response is pretty clear (we weren’t sure about it in-house either). We’ll be changing it.[/color]
[color=#009900] [/color]
[color=#009900] - Land battles aren’t anything you can encounter on the map - they show up in some story choices.[/color]
[color=#009900] [/color]
[color=#009900] - the all-visible-branches is confirmed as an issue that’s fixed by checking for new content. It sounds like the update hasn’t run cleanly for some folks - if you delete everything in the /entities folder in your AppData/LocalLow/FailbetterGames/SunlessSea folder (or, um, whatever the weird equivalent is with Macs) and run another update, that should fix it.[/color]
[color=#009900] [/color]
[color=#009900] - &quothaving enemies ‘use’ their first skill immediately on hitting ‘Resume’ for the first time puts the player at a small time disadvantage&quot - I’m guessing you haven’t noticed you can issue orders while paused. :-) (If you can’t, it’s a bug, tell us!)[/color]
[color=#009900] [/color]
[color=#009900] - New islands are still quite spartan! More content is coming, oh yes. Pigmote Isle should have content - I’ll take a look at why it’s not showing up later today.[/color]