Ship permadocked after Emerald Patch

I wasn’t sure where to put this, but my game ran into a rather nasty bug after what I’m assuming was this last patch. Actually, I’ve run into quite a few bugs, but I’ve been able to ignore most of them until now, and didn’t really see anywhere to easily report them.

I was docked out at the lightship above Rowena’s Rocks before the patch. After the patch this lightship appears to have shifted down to the left, and my ship did not shift with it.

Instead I was docked out in the middle of the zee, to the left of the unnamed island above Rowen’s Rocks. I had the option to Launch, but not matter how many times I tried to choose the option, hotkey or otherwise, the game would not process it.

This effectively made me unable to continue my game, and I had to revert the save folder back to a previous day to remedy the issue.

I believe this may have been due to the map shifting indicated in the Emerald Patch.

While I’m posting this I will mention the few other bugs I have run into off the top of my head.
-You can press Full Power while docked (which I tried when I was stuck). You should probably not be able to do that, as all the flavour text that applies to it (including Engine Overheating) can be experienced while docked.
-Moody’s Light appears to not provide a terror de-buff. If this is intended I would suggest a visual indicator. Perhaps make Moody’s Light a red tint, or any light that does not provide terror de-buff’s a different tint.
-When entering into combat against vessels very quickly after choosing to loot and scuttle a previous vessel (EX when fighting two Pirate Steam Pinnace’s, right next to one another), you will not receive the loot from the first combat. The combat prompt from the second battle will precede the Cache of Curiosities prompt that you would have otherwise received from the first battle. When you choose to loot from the second battle you will receive a bugged Cache prompt (EX You now have x40 a Cache of Curiosities) and you will only receive one cache from the first, or more likely second, battle.

Despite the mentioned bugs, I greatly enjoy the game. Thanks for all your hard work.

I have the same problem except I was (am?) docked at Shepards isle. Restoring my save folder did not work. Still stuck and game is unplayable.

I’m having the same problem, and my game is basically unplayable right now. I’ve sent in a bug report.

I encourage you both to file bug reports. Scroll up and read the stickied thread labeled &quotFAQ and Bug Reports&quot :)

(I have the same issue, btw. I just filed my bug report.)
(Edit: &quotboth&quot refers to the first two posters, I got ninja’d.)
edited by cjo on 7/30/2014

[li]ditto & ditto…

update your client fixes it.


[li]dude - Nameless, you’re awesome.
[li]thanks a ton for that insight.
[li]open Steam account, download automatically runs, reopen Sunless, update new stories, and it runs like a charm.
[li]best curse-lifting trick ever.

Moody’s light still isn’t fixed? That bug has been around since a few weeks before the curator patch at least.

Is there a similarly effective fix for non-steam downloads? Mine comes down from Humble and a reinstall hasn’t helped.

[Edit: I tried again and it worked. The above is untrue.]
edited by Leukorax on 7/31/2014

It happened to me when I wanted to leave the port of a saved game from before the Emerald path (but, strangely enough, not from another savagame). During my current game, that I started anew after the patch, it has never occurred for now.

Where are sunlesss sea save files located? Afraid to reinstall and lose my progress as im having the same problem

[color=#C2B280]We’ve released a hotfix for this, v0.5.2.1478. If you’re using Steam, it should download the fix automatically. If your version’s from Humble Bundle, it should be available later this evening there, too.

Trenloco: saves are stored in a different directory, so they’ll persist even if you reinstall.[/color]

To clarify- this will require a redownload, not just a content update, correct?

[color=#C2B280]Correct. Anything that changes the version number is a full patch.[/color]

Well that certainly reduced my nervousness about whether I had enough fuel to get home from the Mourn ;) Thanks for the lift!