How to travel?

I have lodging named a Cottage by the Observatory, but there is nothing on travel map that I could click. Is this bug or I’m missing something?

It should be in your inventory. Its just another lodging, which is in the upper right of the map.

Oh, found it from inventory. Thanks

Hmm I used key from my inventory and wasted 3 actions to move and nothing happened. Travel map is still empty. Is there any reason to move to lodging?

Your various Lodgings don’t appear on the map - the generic icon at the top right always represents whichever one you’re living in at the moment. Only two things change depending on which Lodgings you’re currently living in: how many cards you can hold in your hand (most of them allow 3; there’s three much more expensive ones that allow 4; those three can be upgraded at Christmas to allow 5) and whether you can draw City Vices cards (there are a small set of special homes, available at Christmas or through Fate-locked stories, that are considered Remote and will remove City Vices cards from your deck.)

Ok, looks like I’m stuck. I can only do Dice games on the quayside or trying get lucky with Opportunity cards.

In the right hand corner just above your cards there should be a button that say travel. Click on that and your map should open showing all the locations that you have available to you including your lodgings. If it is not there you will need to send a bug report to Failbetter.
edited by reveurciel on 4/18/2016

I have examined every centimeter of travel map and there isn’t anything that I can click. Yay, time for a bug report.

If you look at the “Myself” page, there is a second image behind the portrait. If you click on that, you’ll see where you are living. If you spent the actions to move there, that is where you will be – and there are the three card slots mentioned above as further evidence (the places you can live when right out of prison only have two).
The individual homes are all combined in the single “Lodgings” location on the map. They do not appear individually. So there is no bug.

&quotDice games on the quayside&quot? - sounds like you’re currently in Wolfstack Docks.

Currently if I click on the Travel button, my map of London looks like this:

I don’t expect you to have all (or even half) of these locations, but are you seeing none of these?
Are you also able to see the icon for Wolfstack Docks itself after clicking Travel to bring up the map?
(I’m expecting you should be able to see about four or five of them - including the one at the top beneath the first two letters of London, with a sign for ‘The Singing Mandrake’. Plus, of course, the Lodgings icon in the top right corner of the map.)

PS:- What happens if you use a different web browser?
edited by Kittenpox on 4/18/2016

When you travel to your lodgings, is there anything under “Open a way to other parts of the City” that you can do?

OMG, this game don’t work with a Chrome. Firefox shows 8 places. Really nice feature.

If it’s still not working on Chrome then please send a bug report here: Enough people use Chrome that narrowing a problem down could be a big help.

I use Chrome on multiple machines as well as on an Android phone, and have never encountered that bug, even though I use a few white-listed extensions to make Fallen London more user-friendly. Have you tried temporarily disabling other Chrome extensions (even if they aren’t FL-related), just to see if anything gives?

I tested without AdBlock, but travel map is still empty.