help me i killed my world

Hi, I’m just starting to play around with storynexus. I have a world with about 10 storylets . . . and I appear to have killed it. Everything looked fine earlier today, and then all of a sudden when I went back to playtest the world all my storylets had disappeared. I have 2 always storylets and a deck of 3 or 4 sometimes storylets that should all be showing up–but there is nothing. The screen has the character name and information on the left as usual, and the Area name at the top–and then a blank space. There’s not even any empty slots for cards or a deck of unflipped cards.

What confuses me is that I didn’t edit any of the preexisting storylets–which were working correctly up till today–all I did in between the world working and the world dying was add some storylets in an entirely different area from the one my character is currently in. The only unusual thing I did was to create some storylets by cloning (my first time doing it this way) instead of by creating new ones from scratch. Could this have caused a problem?

I’ve tried using the debug powers to get my character out of wherever he’s stuck–giving him A Stranger again, giving him a quality that sparks a Must storylet, flat-out giving him a card. None of it did any good. I can still play individual storylets from the card-editing screen, but once I’m through with the single storylet, I click onward and I’m back to a blank playing screen.

Obviously, I don’t really expect anyone looking at this to magically know what happened with my world, and it’s probably not very possible to diagnose issues from outside a world. But if anyone has any ideas of things I might have done wrong, or advice on how to troubleshoot my own world, I would really appreciate it. I am so new to this, I don’t really even know where to start looking for the problem.

I had a similar situation a while back, and tried these same things, though playing a single storylet from the edit screen worked for me. Maybe a stupid question, but did you make sure all the qualities you edited with debug were back to normal before playing a card? Alternatively, and more drastically, create a card that kills the character, and play it from the edit screen. Then try replicating the issue with a new character.

WordsLikeWeeds: does your character have a Key of Dreams? That’s a likely cause if the storylets are visible in the editor but not in play.

ETA: all storylets are created with Key of Dreams, min 1. For some reason, creator characters sometimes appear not to be. Setting your Key of Dreams to 1 might fix.
edited by levineg85 on 3/29/2013

Yesssssss!! I still don’t know what went wrong, but creating a card to kill my character and restart the game worked. Thank you both for the help!

Not a problem! I still think it was a Key of Dreams issue, though, and might be worth mailing to so FBG can look into it.

And: welcome to StoryNexus!

It’s possible, but if it was the same bug that I encountered, I doubt it was the Key of Dreams that did it. I can’t remember exactly what I was doing that caused it (other than that I was changing some attributes with the debugger), but we didn’t know what the Key of Dreams was or what it was supposed to do, so we removed it entirely. My character didn’t have it, and none of the storylets require it. It might have something to do with setting transitions, though; that’s my best guess for what happened on my end. Without getting too much into the details, I think it may have tried to start a setting transition while I was already in the target setting (in my case, because of messing around with debug). Perhaps something similar happened on your end?

That’s one of the other thing likely to cause the “I can’t see any of my storylets!” bug, yeah. :)

(Also a possible culprit: improperly setting the storylets’ Area/Setting. But since those default to the starting Area and Setting, it’s relatively harder for them to go wrong.)

Hi… sorry for resurrecting this thread, but I have a similar issue:[li]

I’ve been messing around with a world, though I haven’t touched it in a while. I decided to work on it a bit more today, so I created a storylet branch to reset the game, so I could play through it from the beginning. The game got stopped, but from then on I’m stuck on the character creation screen. Entering a name (and accepting the terms) doesn’t start the game, it basically just makes the login text disappear.

I tried debug, but it seems the new player character never even gets created. Debug doesn’t recognize the name, and under analytics, the number of characters created doesn’t go up, with the latest being from June 2013.

Thanks in advance![/li][li]
[/li][li]Edit:[/li][li]The symptoms seem similar to this:[/li][li][/li][li]…but there is no storylet without a title. I did everything that’s written in that thread just to be sure, but the issue must be something else.[/li][li]
[/li][li]Edit 2:[/li][li]Trying &quotplay this storylet&quot gives me a general error message (, though that’s probably because I don’t have (and am unable to create) a character.
edited by Vojtěch Kynčl on 7/9/2013[/li][li]
edited by Vojtěch Kynčl on 7/9/2013

…and it’s fixed itself without any input from me. I was actually about to start the world from scratch, so it’s a good thing it’s fixed now.

I have had this happen in my world under two accounts…but it never fixes itself :(

Sorry to hear that. I’d like to help, but since I had nothing to do with the solution, I have no idea…