Game Crashes on Startup. Unable to Play (Steam)

I tried emailing support about this issue a few days ago but haven’t heard back from them. I am unable to launch the game from Steam. The game crashes immediately after the title sequence. I have tried uninstalling/reinstalling the game, uninstalling/reinstalling Steam, rebooting my machine, and nothing seems to work. Here is my output log:
edited by Homestar on 7/7/2017

While I am neither a Failbetter dev nor do I play one on TV, I do have an opinion on your log. The culprit could be here:

Is there anything unusual about your Steam setup? Are you starting up offline, for instance? (That shouldn’t matter, unless your Steam installation is corrupted somehow.)

Have you installed a Steam authenticator that might not be authenticating your device?
edited by slickriptide on 7/7/2017

Thanks for the reply @slickriptide. I saw that line too which is odd because C:/buildslave/ doesn’t exist on my PC. The only thing “non-standard” about this installation is that I have the game installed on my “G” drive with all of my other Steam games. Perhaps the game expects it to be installed in the default location?

Doubtful. I have my steamapps folder in different locations on different computers and it’s never been a problem. This seems more like your Steam client is failing, or something is interfering with the steamlib API used by Sunless Sea.

It might be a good idea to post this at the Steam forums. I have a feeling that Failbetter pays more attention to those than it does to these forums; at least for this kind of issue. If nothing else, you’ll be more likely to have it be seen by other players who might have already dealt with a similar issue and solved it.

Steam Sunless Sea Discussion Board
edited by slickriptide on 7/7/2017

Thank you. I will try that.

Here’s an excerpt from one of my own log files for the same “launch window”:

Either your Steam app isn’t running or something is blocking Sunless Sea from communicating with your Steam app.