Force equip

Just a quick question - I was assuming that auto-equipping an item in a slot that’s limited by area worked whether or not the character was in that area, and was going to use that supposed set-up to add things to the character that they could do then remove (until they were removed by an event). Negative mental states, things such as that.[li]

Anyway, upon testing, this appears to fail silently. That’s fair enough if it’s working as desired; I’ll just have to find some other way to do my thing. But maybe it’s a bug and is meant to work as I thought it did? Anyone got any idea?


I had the same issue in Final Girl - I found much to my chagrin that the character could un-equip her lost virginity when I tried to force equip it in a location where it was prohibited to equip!

I ended up writing a brief cutaway scene that secretly moved the player to the location where it could be equipped, auto equipped it, and then moved them back.

I agree though that it seems like the author should be able to do/force stuff that the player cannot, including forcing the player to equip something.

Yes, I was considering that method too. It’s a bit laborious, but I guess it would work! Ah well.