Bug: Chart has gone blank, all land-masses gone.

Hello. I just got back after being away and downloaded the latest build from Humble, as well as updating content ingame. However, when I loaded my save at Port Cecil, my ship was just sat there in empty ocean. There was the usual ‘Port Cecil’ in writing but nothing else. I sailed NNE towards Mount Palmerston but again, no land masses. Enemy ships seem unaffected/still exist.
Also, the landmasses have disappeared from my chart entirely, only the names remain. I tried starting a new game but it seems Fallen London has disappeared too. Storylets were there but visually there was nothing but open sea.

Perhaps this was caused by me not being able to download and install the last build (from 24th May) first. If it is this then it’d be right handy to know how/where I can download the earlier build because as far as I can tell there is only the latest build available on Humble.
Ta in advance and let me know if I should’ve posted this elsewhere. Just wondered if anyone else had this issue or knew of a fix.

[color=#009900]Alas, I’m afraid saved games from 1.2 are now broken - you’ll have to start a new game in the current build to see the map. The same goes for the shipyard q in the other thread. If it’s any consolation, going through an intermediate build wouldn’t have helped - unless you started a new game there - and all the story content and stats attached to your character are sufficiently out of date that it would be a weird experience anyway.[/color]
[color=#009900]That should be, we hope, the last breaking save state change. There may be some weirdness when Amethyst, the next update, drops, but that should just be things like log date oddities - we’ve put work in to ensure saves from here on in will be stable.[/color]

Alas, I tried starting a new game but the bug persists. I even tried uninstalling and just reinstalling from the current version but for some reason my saved games are still there and when I start a new game I am adrift in an endless ocean next to the words Fallen London.

[color=#009900]Your saved games live somewhere like C:\Users[your username]\AppData\LocalLow\Failbetter Games\Sunless Sea - uninstall, delete everything in there, install and update content, and all should be well. If it’s not, drop us a line at sunlesssea@failbettergames.com and we’ll dig into it![/color]

That’s done it, ta. Also, I just sailed past Low Barnet and it looks awesome! For anyone else confused at windows 7, you have to go to Folder Options and under the ‘View’ tab tick the ‘Show Hidden Files and Folders’ box to get Appdata to show up. I deleted everything there like Capn Kennedy said and then re-installed from the new Humble version.