Broken map on linux

Hi guys,
my Sunless Sea map does not work anymore. The map is blank (white). There’s still some text, but no actual map (textures). The game was working fine yesterday and I made no changes to the game or my system.
I’m on Ubuntu 16.04 Mate. So far, I’ve tried restarting the game and the system. I also tried disabling my windows compositor. Finally, I already re-installed the game, which included deleting the game’s data in my .config/unity3d folder. It’s still broken. This is on a Thinkpad T430, Core i5 / HD4000.
Maybe one of you has dealt with this problem and knows a solution?

Do you use Steam? The game may have updated automatically; new patches are going out in preparation for Zubmariner. I haven’t heard of this particular issue before but there are lots of bugs in need of quashing.

In any case, this sounds like something to report to for support.

Thank you, yes I do use steam. I’ve mailed support and sent them my log file. Hopefully someone is going to have some kind of solution.

I am having the same issue on Ubuntu 14.04.

I have the same problem using Linux Mint 17.2 MATE 64-bit.

Guys, could you let them know? That is, could you create a support ticket? Since this seems to be a problem with various linux versions (all Ubuntu based so far), they may be more inclined to take it serious. I’ll also try and run the game’s Windows version via wine. Wouldn’t be surprised if that’d fix it, although performance may suffer.
edited by Deepflows on 9/28/2016

As expected, the problem is not present when running the Windows version via Wine. Performance suffers on my laptop, though. I really hope a fix is inbound.

Sent mail to support now

[color=#3399CC]Hey folks,

I just wanted to reassure you that we are looking into this issue. We’re hard at work on several fixes and this will be one we’re keen to address. If you do encounter issues, especially if these issues persist after an update please do contact so we can gather information from you.


We’ve now fixed the map bug and that fix will appear in our next update.[/color]
edited by Mac on 9/29/2016

Awesome! Any ETA on the update? I’m going on a trip over the weekend and was really hoping to spend some time with Sunless Sea on my laptop, which is a Linux-only machine.

Alternatively, is there a steam branch which has an older version which didn’t suffer from the map bug? Or is there some way I could implement a workaround myself for the time being?
edited by Deepflows on 9/29/2016

So, any updates on that patch or some workaround I could use…?

[color=#3399CC]This fix is now live on the public version of Sunless Sea, if you experience further issues please get in touch at ->[/color]