Unable to find Fallen London [Can't connect]

Greetings fellow Denizens

I’m having some problems connecting to the Fallen London page. I have found previous posts mentioning this problem and I’ve followed the advice I could find, such as cache clearing, using a different browser, manually entering the page address in it’s various forms etc, but to no avail.

What’s very strange is that I can connect to all the other StoryNexus pages without issue.

To be clear, the message I get is &quotFirefox can’t find the server at fallenlondon.storynexus.com.&quot

Is anyone else having this problem and does anyone have any advice?

Many thanks in advance!

I am also having trouble connecting.

Me too, even though Down For Everyone Or Just Me says it’s just me.

Well, at least we know we aren’t alone! :)

Same here. I am using Chrome, and cannot connect either.

Me too, just as Gillsing is saying. It went down few minutes ago.

Edit: Browser is Opera Next
edited by Mallachi on 8/26/2014

But I can’t be late to my etiquette lesson! How will that poor Rubbery Man know why people hate him if I don’t teach him?!

My error message says something about &quotHost not being resolvable,&quot which is either a DNS error on our end, or on the server’s. From the commonality of the error, I suspect that it is a temporary issue with the FL server. It’s happened to me before.

Edit: It seems to be Fallen London specifically; I can access the main Storynexus page just fine.
edited by Rackenhammer on 8/26/2014

That was very strange - I could get the logging in page for a moment, tried to log in, then lost it all again.

How very peculiar!

I was having this problem and rebooted my router and am now back in, it might just be a coincidence though as other people are having problems.

I spoke too soon, I’ve got another DNS lookup failed message:(

Rebooting solved the problem for me as well.

I’ve noticed few things:

[ul][li]It works now on computer and I haven’t done anything else with it than turning it off and on,[/li][li]I still have this problem on my smartphone over the wi-fi network (I receive message about problems with answer from DNS)[/li][li]But the cellular network works perfectly.[/li][/ul]I have no idea what it can be.

Edit: Gone again…
edited by Mallachi on 8/26/2014

Edit2: I don’t want to post another message so I’ll write it here - My router was using google DNS ( as a static one. I’ve disabled it and now everything works.
edited by Mallachi on 8/26/2014

I just managed to connect and draw all my cards and spend a bunch of actions. Perhaps my ISP finally received the new DNS or whatever caused the problem? Or maybe the problem was all server-side?

Restarted my machine and it’s working for me now too. Very odd.

Cross all 13 fingers that it remains!

Nope, I’ve lost it again. sniffles

Yeah, me too. Evidently I should have used all my actions instead of saving half of them.

Raises hand Aye
edited by Shadowhand on 8/26/2014

Having the same problem. If I clear my DNS cache, I can get it to work for a few minutes, but it always goes down again. Oh well, I guess it’s a sign I should do work or something.

[color=#009900]Henry’s taken a look at this - there was an issue that we think is now resolved. Let us know if it’s still misbehaving - sorry for the trouble![/color]