Help please? I can't get gifting/friending to work

Some kind person has sent me a glass of teeth, and I would love to return the favour, but I can’t figure out how to add them. I tried entering their name on the account page, but when I hit enter the dark grey box just went blank, and they aren’t on my friend list.
The page that comes up when I attempt to send a glass of teeth from the “Celebrate The Feast of The Exceptional Rose” storylet also seems to be missing bits of text.
It looks like this:

Surely that can’t be right? Is it just me? What am I doing wrong?
I haven’t added friends for this game before. I haven’t needed to, and I’ve made it all the way to the content limit in a lot of places, so it’s a little irksome that it’s a requirement to advance in this event. HOWEVER, maybe it’s about time I did grin I would like to participate, so some help would be appreciated.
I hope I’ve posted this in the right place. Thanks in advance :)

I had the same problem, it’s a remnant of when they hooked in SN a while back.

Click on the “Click here to find more friends” link. That should take you to the new SN version profile. On the right side, if you have linked the game to Twitter and/or Facebook, you can click the appropriate button(s). The game will go and fetch your list of friends who are also registered through that social network.

You should also be able to add people by their email, if they used that to register - though I haven’t tried that part myself.

I appreciate the help, but my game isn’t linked through facebook or twitter, I UNLINKED both as soon as I had the opportunity. None of my friends on those networks play, sadly. I did follow the “find more friends” link, which is where I had the failure with the grey box.
There must be a way to add somebody based on their name, because that’s the only way my mysterious tooth-gifting acquaintance could have sent me anything. But I can’t get it to work.
edited by Inky Petrel on 2/15/2013
edited by Inky Petrel on 2/15/2013

I’m not entirely sure what causes the blank box. I got it a little while ago, but that was because there was a space at the end that shouldn’t have been there. Another account encountered a bug that created a doppelganger Storynexus account with the same exact ID, resulting in nobody being able to add him until he tracked down this unfortunate account to change its Storynexus ID manually.

Oh my, I’m terribly sorry! More than one person trying to add me as a friend today through the SN system has received nothing but a blank page; it must be a bug on my end, I’ll see if I can get it fixed.

Ah, perhaps it’s not something terribly obvious I’ve missed then :) Thanks! I’ll try again tomorrow.

Edited to add: Alas, I am having this problem with anyone I try to add, so it appears it’s not something at your end Corentin Os. I’ve tried to add several people now (including one friend who sent me a very sorry looking pink cat, poor creature! :p) Using their character name resulted in a “not found” message, and using their other name got me the blank grey box again (after a moment of “loading”). Is anyone else having this problem?
edited by Inky Petrel on 2/15/2013