A Ghost Deck appears...

Hey,
I make (for my own enjoyment, and testing SN engine) a light sci-fi game. I really liked the “Heists” in FL, so I tried to re-make them, as “missions”. The problem is, when I move the character to a new environment, and assign a new deck to him, a weird “ghost deck” appears too. It is especially weird because the character was moved previously (from the starting area to the “on orbit” area), and it didn’t happen. As far as I see, this is a graphical bug, as it doesn’t effect logically anything.

Screenshot:
https://dl.dropbox.com/u/6602349/SN_GhostDeck.jpg

the url is:
http://undercontrol.storynexus.com/s

Note that I am not a native english-speaker and not a great storyteller, so don’t expect anything serious.

You can reproduce the bug (or can you?):

  • go to the URL, create a new char
  • get your ship
  • you are now moved “to the orbit” location, maybe play a few cards if you want, marvel at the cliché, cheesy, badly written story with all its glorious grammatical errors
  • choose the “go to the mission” card
  • follow the (currently only) options, and begin the mission
  • observe that there is currently 2 decks instead of one, but one is a “ghost deck” (cannot be clicked, etc).
  • you are free to “finish” the mission, just play the only playable card, it doesn’t matter if you fail, it still counts towards finishing the mission
  • after the mission is over (played the card 3 times), you are automatically returned to the “on orbit” location, and the ghost deck is gone. On the next mission, it will return to haunt again.

Well, this is it. Is there a way to get rid of that ghost deck?

best regards,
Kalamona
edited by Kala Mona on 4/3/2013

I did a little testing, and like I thought, it looks like it’s because of the length of your deck name. I had a similar issue in another world, with just the left border, and a quick test confirmed it. Just make the deck name something (much) shorter and the ghost deck should disappear.

Wow! Thank you, it worked!

I’ve gotten that too. Good to know!